VMware Blacklisting Drivers in ESXi 6.0

Recently I purchased a new lab computer to be able to shift my workloads out of VMware Workstation to a dedicated box. I didn’t have a large budget as I plan to purchase at least another one or two down the track. For this reason I opted for an AMD system, I was able to get 6 cores instead of 4 cores that comes with a similarly priced Intel CPU. All is well and good, the parts fit together and I am able to squeeze 32Gb of RAM on to the board easily.

Everything is going well until it came to installing ESXi 6.0. I start to go through the prompts to accept the EULA, scan for drives, select drives, etc. Until the final stage where it starts to install and there it is, “No Network Adapters”  – This was not what I was expecting to see.  Realtek!  After a little bit of googling ESXi and Realtek 8019 – I hadn’t come across it previous, but VMware has been removing Drivers that were valid in 5.0 and 5.1 – this isn’t a real issue.

I was able to find a .vib file for the driver I required. Oh boy, this is a good thing. So I went ahead and used ESXi Customizer to insert the .vib to the ISO. You beauty, this surely will get me out of the water – sadly, no.  I made it all the way to the same spot as previous, however, this time I was presented with a much larger error message “This driver *blah* is obsolete”  and some recommendations.

Once again, I started to google and came across some interesting articles. In vSphere 6.0, not only are older drivers removed from the ISO, but they are also blacklisted. I don’t understand why VMware wants to blacklisted, but I’m sure they would have a good reason to do it.

To overcome this, I found an excellent link to a repackaged driver .vib – you can get it here,

I once again created my custom ISO using ESXi Customizer and was able to fully install ESXi without a hitch and able to connect to it via C# client.

 

I highly recommend checking out Andreas Peetz blog here for more information on how to run his ESXi Customizer and also get around driver issues with vSphere 5.5 and 6.0

Thank you.

Advertisements